Can't Update This Collection

I recognize that this topic has come up before. I have reviewed those threads in the hopes that a solution in those would solve my issue. Sadly, it has not.

I’ve now started getting this message on a specific album. In fact, I have deleted the album from publisher (including the option to delete from service) and set it back up again. I added images to this album that had also just been successfully published in a different album (just to test the images themselves).

I can confirm that all images are accessible. The internal drive they are store on is mounted. Right clicking and choosing to Show in Finder from within Lightroom finds the file as expected. Yet when I go to publish, I get the message below. Could it be the album itself? The album sits inside an Album Set. But so does the other album I had the ‘test’ images in (which has been successfully published). The albums in each album set are created similarly with the primary different being that one is a downloadable album and the other is an album of images for purchase.

UPDATE: I should add that I’m using v7.0 of The Turning Gate Publisher. I’m also up to date on v 5.01 of Backlight.

UPDATE2: I realize I should probably just let this settle until someone has had a chance to respond, but I’m now concerned because ANY new album I create is flagging this message. I’m ensuring that I’m not repeatedly using the same images. I’ve tried random images from other folders in my library and I get this message each time. If I take an item in an existing album, mark it for republish and republish, it works just fine. But it seems that - for now - any new album I create is not enabling me to publish - regardless of where the image is coming from within Lightroom.

Screen Shot 2022-09-03 at 11.23.56 AM

Hi @scottblackman, I’m not sure what is going on. We’ve only ever had that message come up if in fact the files haven’t been available (e.g. because they reside on an external drive that isn’t connected).

Technically, this message is caused by not being able to create the rendition file, but that has only ever happened when the source file hasn’t existed.

Can you try the following:

  1. Rename the file ‘ttg.log’ to something like ‘ttg_20220904.log’. This file can be found either directly in your Documents directory or in a subdirectory of the Documents directory called LrClassicLogs.
  2. Use LR until you see the error again
  3. Open up the ttg.log file in a text editor (which should have been created afresh after having renamed it)
  4. Look for messages starting with ‘unable to create rendition for’.

The message will state whether the file size is nil (presumably meaning the file couldn’t be found) or whether it’s 0.

In the message is the file path. For me, an example path is /var/folders/nw/hxy21cqs1nxdks7_wl214zm80000gn/T/20110821-0142-4.jpg. Can you then take the directory name and see if it exists in Finder? e.g. in finder visit the ‘Go’ menu and click on ‘Go To Folder’ then paste in the directory name (e.g. /var/folders/nw/hxy21cqs1nxdks7_wl214zm80000gn/T).

Once in that folder, can you try to drag another file into it, to see whether files can be saved there?

Thanks for the reply and guidance.

I did exactly as you instructed and renamed the ttg.log file to ttg_20220904.log. I reopened Lightroom Classic (Lightroom Classic version: 11.5 [ 202208080927-8a575c91 ] for what it’s worth). Went to a new album set. Added a single image and clicked publish. Immediately got the message.

Opened the newly created ttg.log file in BBEdit and found this row:
2022-09-04 11:07:47.4880000-05:00, DEBUG unable to create rendition for /var/folders/2w/c0pvn4cd77ggnxzl6rzk77_m0000gn/T/20220903_.jpg - fileSize is nil

I pasted the path to the folder in the Finders Go to Folder… menu item /var/folders/2w/c0pvn4cd77ggnxzl6rzk77_m0000gn/T Whilst in the folder I added another image directly at the root of T and it allowed me to save a file there without incident. I also added a file - just for good measure - at the root of c0pvn4cd77ggnxzl6rzk77_m0000gn just to ensure that worked as well. And it did.

So…clearly stumped at this point.

For additional color - and what confuses me further - is that I had earlier in the morning yesterday taken several hundred photos from a prior night football game and put them into an Album within an Album set. This was an album of images set for sale. I did everything I always do nearly every Saturday morning after a game and everything work as expected. No issues. Nothing in anyway unique from what I’ve done hundreds of times. All I’m doing is creating a new album for the prior nights game in the seasons Album Set.

While that album was publishing, I took some images from that same game (images that were also in the prior album set/album referenced above) and also put them into another album that I have where I put a handful of images from each game for the group director at the high school to have to use for social media posting. It was here that I had my first issue with the Can’t Update Collection message.

And from this point forward, any albums I create within this Lightroom library, whether in an existing album set, in a new album set in no album set at all, I get this message.

I’ve done some of the obvious things like reboot my Mac. Validate that software was up today, etc. But at this point I’m hesitant to do any more monkeying around until you have a chance to further ponder this issue.

I’m running on a Mid-2010 MacPro with upgraded processors and memory running OpenCore 0.8.3and running MacOS 11.6.8. While not exactly a standard issue machine, I have been running everything I’ve addressed above on that configuration for quite sometime without incident.

Happy to provide whatever additional detail and/or access you need. Including being willing to actually hop on a web meeting if this issue is so odd that you need to dig further. Whatever is easiest for you to have the facts you need.

Hi @scottblackman, thanks for the further details. That should rule out any issue in being able to write the temporary file to that directory.

A few more things to try:

  1. Can you try to export one of the images that won’t publish? (using the non-Publisher File > Export)
  2. Can you right-click one of the images that won’t publish and select Show in Finder, to see whether the image is there?

Am I able to try to create a hidden album on your server and publish to it? If so, can you send me a message with a Backlight admin login, and let me know which template you’ve been using for these problematic albums?

Another thing to try is for you to publish to my test site. I can pass you credentials for that.