Can't upload images BL3 error code 413

I’m trying to add images to an existing BL3 Client Response Gallery - nothing will upload - getting code 413.

The images are similar to previously uploaded images (similar size from same camera).

MacOS Ventura 13.0.1, M1 Mac Studio, Latest Adobe Lightroom (LRC)

what version of php is your host using?

You should be able to find out in the Backlight Admin. I don’t recall exactly where the link is in BL3, but look for “View PHP Info”

According to the Backlight page - PHP version 7.4.32

I don’t remember what the php compatibility was for BL3, @Ben would probably know. But if nothing else on your site has changed, perhaps the problem is due to your host changing php version. Just a guess.

Thanks Rod --how do I reach Ben to find out the correct PHP?

You can wait for him to chime in here or you can click on his name in my last reply and send him a private message. It may not be a php issue so he might also need a Backlight admin login and perhaps even ftp access.

We support up to PHP 8.1. PHP 7.4 is supported.

413 is a server error meaning “payload too large”. This has come up recently with users running sites on Nginx. Who are you hosting with? Do you know what web server they are using?

If you visit the PHP Info page in your Backlight admin and search the page for the text “nginx”? If you find anything can you copy the details here? If not, can you verify that searching for “Apache” matches anything?

If this is your own server and you are running Nginx, then there is a page here that outlines how to fix this:

Hi Ben - thank you for responding.
The Nginx search came back with nginx/1.23.2
the Apache search returns: Apache 2.0 Handler Author: Ian Holsman, Justin Erenkrantz (based on Apache 2.0 Filter code)
The error occurs if I’m trying to upload as little as one Lightroom image (RAW).

Thanks, @chbphoto. It looks like Nginx and presumably the setting for client_max_body_size is the culprit. The default Nginx setting for this is 1MB, which isn’t very large for image uploads.

Thanks again, I’m glad you’re on top of this issue.

1 Like