Cart order acknowledgment email - download link doesn’t work

So, I’ve photographed an event today and tonight had customers saying that they’ve received an order acknowledgment email with a download link, but when they click on the link nothing happens. Most of them seem to be on iPhones. I’ve tried copying the link on my own iPhone and iPad and I get the option “View”or “Download”. “Download” does nothing, “View” opens the file and then I can save it to photos.

I’m sure this worked fine with BL4, I’ve never had customer issues with digital downloads before. Does anyone have the same problem or able to check if this works with their website please?

It’s working as expected on my test site for downloads to both desktop and the iPhone. On the phone, I tap “download” and the image is downloaded to the phones “Files” folder.

Maybe if you share your settings (renditions created by Publisher? Do you upload the high res images as needed?, etc) someone could try a 1:1 comparison

Thanks for taking the time to look at this Rod. Albums are published from Lightroom, cart version 8.1.3. I’ve noticed I’m downversion for some other modules which I’ll update when things quieten down later this week.

I think this is something possibly introduced by an IOS update - looking more closely this morning if I click on “download” the only thing that changes on the phone (iphone 12, IOS 16.4.1a) is a small circular icon to the left of the address bar changes blue - clicking on this then reveals the download. Unless you look closely it looks like nothing is actually happening.

Interested to know if you get the same behaviour or if your test shows the image immediately - e.g. by pressing “Download” does the image display as well as download to the files folder?

While I’m at it, there’s a couple of fields in the download link info showing as “undefined” - any idea how to clean that up please?

That’s what I’m seeing too. I get the option to view or download. I tapped “download”. When the down arrow appears, I tap on that and then tap “Downloads”.

The word “undefined” seems to only appear at mobile sizes. One of the data fields is empty. The other has the download link.
That will be something for @Ben to look into.

Thanks for checking Rod, clearly too subtle for my customers and me as well! :smiley: I actually think it’s a bit of an IOS UI oversight, because a users hand would be obscuring the display and it’s not something that’s immediately obvious. I’m sure in previous versions of IOS pressing “download” actually displayed the image.

I’ll wait for @Ben to get back to me re the “undefined” fields. Really appreciate your input, thanks again.

I use Windows and if I reduce the width of the browser (Firefox) to mobile size, the two “undefined” attributes show up