Contact form field issue

Hi all,
even with an empty Contact Form design, the Address field is still visible.
How to get rid of it?


Best regards,
Oliver

@Ben will need to look at that. I suspect it’s there because of the Honeypot, even though it shouldn’t be showing.

Before activating the Honeypot, did you update module-admin from the Backlight Modules page?

I’m guessing that field can be hidden with custom css, but I don’t know if the bots would still be fooled into filling it out.

Hi Rod,

Before activating the Honeypot, I did update module-admin.
And indeed the “Address” field is gone if I delete “define(‘ENABLE_HONEYPOT’, true);” and rename the file to env.php.skel

Will there be any solution in a future update or shall I use Google reCaptcha with an enhanced GDPR Notice? (I’m in Germany / Europe)

Best regards,
Oliver

@Ben will need to address that

What generation of plugins are you using? Pangolin or Kookaburra?

We did drop support for the honeypot and enabling it for now is a workaround. We’ll look into the display of Address when we have a proper look at reenabling the honeypot functionality. In the meantime I suggest disabling it.

Hi Ben,

thank you for the information.
On my new website I only use Kookaburra for now because I will see how far I can go with it.

Best regards,
Oliver

1 Like

Hi Oliver, I was able to work that out from your form. I’ve tried the honeypot on Kookaburra and don’t see the Address field. There is CSS to hide it. I’ll revisit this with Matt as I work further to add back the honeypot as a configurable option in the admin interface.

Ben, thank you for your quick reply.
I activated Honeypot again and on my contact form it shows the address field. Also a message via the contact form is not sent.

Best regrads,
Oliver