Contact form issue

When I tested the Contact form functionality, I got the attached error message.
FYI - My email goes through the University where I work, not to DreamHost where my website lives.
I assumed the Contact form would work since worked perfectly with the TTG add in modules I had used prior to updating to Backlight.

Thanks, Paul

Screen shot that should have been attached to my previous email.

Until Ben can take a look, have you seen this:

and since the error message includes something about recaptcha, try disabling that.

I found email settings and attempted to configure as relevant to my email. However, I don’t think
SMTP is relevant since I have a MS exchange account. Please advise. Thanks, Paul

have you created an email account with your host?
If not, do so.
Then try this: put that email address in the Vendor Email setting and your university email address in Site Email setting.

(I just tested this using my msn email address and I received email at my msn address)

Hi Rod,

Thanks for your directions. However, I already have 2 email accounts on other servers
I would rather not create and pay for anymore email accounts. Is there any way I can use the Backllight Contact Template without setting up an Email account on DreamHost? Thanks, Paul

I don’t know, I’ve never tried. I think that’s what the smtp Mail Send Type is for.

Ben will need to weigh in though.

If you have a WordPress blog, you could use one of the free contact form plugins like Contact Form 7 on a WordPress page.

Sorry to be late to the party. This was caused by a bug that affected contact forms when reCAPTCHA was not enabled. I have applied a silent update to address this. To install it, visit Backlight Modules and click reinstall for the line for module-admin.

Better late than never. Thanks. You fixed the issue. Now works.