Controls in slideshow on home page

I’ve added a Galleria album auto-playing slideshow to my home page. I don’t want any controls at all showing. I’ve removed everything except the forward/back arrows on either side of the image which appear every time I move my cursor into the general image area. Can’t for the life of me figure out where and how to turn those off! I’ve tried every parameter in the Galleria template and the home page (I think).

I know it can be done… What’s the secret?

Custom CSS

This should work:

.galleria-image-nav {
  display:none;
}

this will affect all Galleria slide shows. If you want to remove the arrows for the home page slide show only, then target that page by adding a body class.

Thanks Rod, I will give this a try.

I haven’t added any custom css before. Do I need to follow the Custom CSS doc guidance of creating an actual css stylesheet with this it’s only content, putting it an the css folder and enabling css in the template? Or, given that this is only going to apply to a single page (the home page) can I just put this in the file along with the html that will use it (with the relevant body class)?

Create a custom css file as directed in the docs is the way to go. You’ll likely be adding to it anyway :wink:

Rod

Did as you suggest - worked great. Thanks for the ongoing help!

Bob

1 Like

I had the same issue and question when I first designed my Backlight site a few years ago. My solution was to clone my Galleria template and make a few settings changes. To eliminate the left and right arrows on my home page, I simply changed the color of the arrows to transparent:

Album Settings > Photo Presentation > Slideshow Controls > Arrows & Controls – Foreground & Background set to transparent (255,255,255,0).

John