Cookies confirmation

Hi,
Every again I have to confirm the cookies. Annoying. Wrong setting or problem?

If you accept the cookies, then you shouldn’t see the notice again for up to one year, or until the next time you delete your cookies.

Do you have any cookie blocking extensions installed in your browser?

Matt - I’ve had my cookie blocking turned off forever and still get the cookie notice nearly every time I go to the website. I thought that was normal

I don’t see it when I visit your site, and that because I’ve already agreed to the use of cookies on the site, and my browser is handling it as I would expect.

You can use the browser console to show the cookies for the site you’re one. When I visit your site, I then execute document.cookie in the console, and I get this:

document.cookie
"PHPSESSID=37f3534e8774fae3018faa31bf95b884; allowCookies=yes; fotomoto_cart_skey_daa188c811eb7520a74f80a37fc8e939e0f927e5=4417c81593972614"

“allowCookies=yes” is used to determine whether or not the notice is displayed. It’s set, and so I do not receive the notice.

If you’re not getting this in your browser, then something in your browser – an extension, or a preference – is blocking cookies, or removing them after a period of time (or maybe on closing the browser?). Or if you regularly use the browser in Incognito or Privacy mode, then it likely won’t store cookies beyond the current session.

To wit, there’s no problem here with Backlight. It’s something in your browser.

Matt - it does not occur on my Mac but does occur on my iPad or iPhone - not sure how to check it on there.

Assuming you’re using Safari, go into the Settings app, find Safari in the sidebar.

In Safari’s preferences, there are a few places you can look (my personal settings in parentheses):

Block All Pop-ups (on)
Content Blockers (9 => using 1Blocker; I had to disable a few default rules, though)
Block All Cookies (off)

Then, in Advanced:

JavaScript (on)

Thanks Matt - I already had all of those settings. If I leave Safari open and close only the website I don’t see the cookie notice when I reopen it. But if I close Safari I always get the notice when I open the website.

I’ve scanned everything I could think of in regular settings and advanced, including the experimental settings and can find nothing. Another one of those Apple mysteries that have been popping up ever since Steve Jobs passed away. :smiley:

Fascinating captain…

I can also see that I need to confirm cookies on https://terrancealexander.com/ after restarting Safari on iPhone. I’ll see whether inspecting the cookies gives any hints to the cause. I’m not home at the moment and without laptop to check.

Ben was able to find a quirk in Safari’s handling of cookies. We’ll effect a change to accommodate Safari’s strange behavior. Look forward to it in the next update.

Thanks guys! Have a safe day.