Download Icon and Image Name Missing in Albums

I have created albums, given permission for download. I have tried all three options. There is no download icon both on thumbnail and presentation mode.
There is also no image name under the images, this can only be seen when hovering over the image. I have looked at the the page template and the album template but can’t find anything that relates. I have edited the album set so the album title does not appear under the album by using white text.
I’m sure this is user error but any insight would be helpful. Thanks.

Are you using Pangolin or Koookaburra templates for your albums?

Did you enable downloads before publishing the albums?

I am using a Pangolin template for my album.
I am using backlight to create the albums so it seems like it is published instantly. But before I put the photos there, I did set up the template to allow downloads.

Download icons are not included with thumbnails.
on the large image, it depends on the presentation.
For single page presentation it should be above the image.
For slide show presentation you need to first click on the image menu icon in the upper right.
can you post a link to an album?

Ok, I see it now. Thanks. When viewing slideshow I need to open the Image Share Menu to see it. In CE4 I was able to put a download icon on the actual thumbnail (by checking the box “Display download buttons on the grid” which was nice because it is right there, obvious, and saves a step. Failing that, is there anyway to have the download icon appear right on the image in the slideshow or to have that share menu default to be open? I don’t have confidence that visitors to the page will be able to figure that out on their own.

Probably not without changing the Fancybox code in Backlight. There are no user settings for either of those options

But users can download an image from the thumbnail grid