How to implement captcha

I had signed up for captcha and thought it was working, but clearly, I have done something wrong on my Contact page at What do I need to do?

Also, I was a member of the old Forum for several years, but I am now considered a new user since I had to create a new account. Can this be rectified?

Thanks for the great help I always receive here.

Take care of yourselves,
Practice Social Distancing,
Wear your masks,
Wash your hands like raccoons, and
Keep your hands away from your faces,

TBC (The Barefoot Contessa, alias Margo Taussig Pinkerton)

P.S. I like the new look of the forum/discourse, even though it will take a little getting used to. Kudos!


Did you enable ‘Enable reCAPTCHA’ in your contact form?


I thought I had, but I cannot find out where to check or make sure it is enabled. Sorry to be dumb on this.



I found the place, and clearly, I already had enabled it. It notes “v3 enabled”

What now?



Good! That’s the setting I missed for a long time…

Looking at the javascript console, I noticed this error message:

Uncaught (in promise) Error: Invalid reCAPTCHA client id:
at Array. (recaptcha__en.js:219)
at Array. (recaptcha__en.js:59)
at (index):171

Please double check the reCAPTCHA values you are using.

Thanks, Dan, but now I feel really dumb. Where do I set them?

Take care,


it’s in the Backlight Settings under Contact Forms Spam Protection
There’s more info in the documentation:

I see that I have v2 settings. Can I just copy them over to v3??? I did, but that didn’t work either!

Thanks, Rod,


Nope, v3 settings are different. You can create them at the same place where you did v2.

There are reasons you might want to use v2 rather than v3. Please see our documentation to help you to make the right choice:

You are right, Matthew. Thanks for the heads up. I’ll to back to v2.

Take care of yourself,
Practice Social Distancing,
Wear a mask,
Wash your hands like a raccoon, and
Keep your hands away from your face,


1 Like

OK, so, yeah… my lack of knowledge here… :confused:

So where exactly do you place the reCAPTCHA code - what page? Or does this go in custom CSS?

    <title>reCAPTCHA demo: Simple page</title>
    <script src="" async defer></script>
    <form action="?" method="POST">
      <div class="g-recaptcha" data-sitekey="your_site_key"></div>
      <input type="submit" value="Submit">

Yes, I read the documentation but it doesn’t say (or isn’t clear) where to place the code.


no need to use code, it’s already part of Backlight. Set up the site key, etc. in Backlight Settings under Contact Forms Spam Protection and enable Captcha in the contact form.

Click on the info icons next to the items in settings for more info

1 Like

Thanks. I got it now (with your help). Also had a hard time figuring out where and how to get to the reCAPTCHA admin console. Finally found it, and apparently, I’d already had reCAPTCHA setup when I was running BL1. Copying those keys solved my issue.

All good now. Thanks :+1:

For a long time reCAPTCHA v2 was working, then something went south. On Google, I get this message:

We detected that your site is not verifying reCAPTCHA solutions. This is required for the proper use of reCAPTCHA on your site. Please see our developer site for more information.

Fortunately, I saved my keys elsewhere, but currently, there is just a simple checkbox, and I want to invoke something less spam friendly, such as the tic-tac-toe grid with images.

Does anyone know how to do this? I find that Google’s help is singularly unhelpful. This is for our contact form.

Thanks, I hope, as there is a disconnect somewhere.


Google decides whether to show a checkbox or the grid of images based on the level of security you have set and whether their algorithm thinks that the visitor may be a bot. This is similar to how reCAPTCHA will sometimes ask you to confirm more than one set of images before proceeding.

The security level setting can be found in your reCAPTCHA dashboard. It doesn’t specify whether to show the image grid or not, but presumably setting closer to ‘most secure’ will make this more likely. If setting all the way to ‘most secure’, I would recommend trying it yourself. It may become very unfriendly to users.

Ben, as always, thank you, and I upped the ante on level. BUT, my reCAPTCHA still says for my contact form:

We detected that your site is not verifying reCAPTCHA solutions. This is required for the proper use of reCAPTCHA on your site. Please see our developer site for more information.

Any thoughts on this?

Take care,


Works for me without issues…

Thank you for contacting us. We will be in touch with you soon.

spam check passed,

I didn’t see any error message.


Thanks so much for checking. Good information, which makes me wonder why Google feels differently, but then, it probably has a mind of its own! Probably takes some time to catch up with itself! After all, for all the hype, the Internet is not always instant!

Take care,


1 Like