Install on public_html folder or subdomain folder with that folder?

Hello, the install instructions say:

"After uploading, your folder structure should look like this:
• public_html/
◦ backlight/
◦ galleries/
◦ .htaccess
◦ index.php
And so, Backlight’s admin should be accessible at"

the path for my PHOTO website is public_html/edo
In the main public_html folder I also have “folders” which hold my other non-photograhy websites.
At the present I am using Turning Gate 3 ONLY on the Edo folder website. So I am wondering where to place the new backlight on my server. WIll it work by just being in the public_html folder or should it be in the public_html/edo folder? Its possible I may use it if for other websites (public_html/xx) in my main public_html folder later in the future.

Thanks in advance for any directions on this


Extra Info:
The main registered domain is
My Edo Photos website site folder path is (“edo” folder contains my entire photo website)

public_html is only used internally by your webhost. The public urls are and

I think it makes the most sense for your setup to have backlight inside the edo folder. This way you can take advantage of all the features Backlight offers. To access the admin panel, the url will be Whenever the documentation refers to the home directory, that would be ..../public_html/edo for you.

1 Like

Thank you Daniel. That’s what I was thinking.
Actually its as a so-called sub-domain which lives in the account Hosting service is Bluehost.

That’s actually a FQDN (fully qualified domain name). In this case, Backlight has to reside in the edo folder to work properly.

1 Like

Thanks again Daniel. Plan to start setting it up today.

Any idea what to do at this step?? (see screenshot) I am thinking the index.php file already there is from an older version of Turning Gate, but I think I need to keep the old one that’s there now until I get the new version running.

ALSO I DON’T SEE THIS in the folder or FTP app:
Important: Be sure to include the .htaccess file. It may be invisible in Mac’s Finder or Windows Explorer, but you should be able to see it in your FTP client; make sure it’s set to show invisible files.

Now I see I was uploading the wrong way. It seems the whole folder uploaded fine. I keep following the install steps now. Sorry for all the panic.

1 Like