Install Problem - Can't get past login page

I’ve uploaded Backlight 3 to my website, and am at the Backlight installer window.

Click [Install Backlight 3]

Next page: Backlight 3 Login Window

Please provide details for your SendOwl Backlight 3 order to proceed with installation.
Order ID for your Backlight 3 purchase: (Enter my Order ID)
Email used for Order: (Enter my email)

Click [Log into Installer]

Next page: Back to Backlight Installer window

Click [Install Backlight 3]

Ditto keeps going round and round. Can’t get past this.

I’ve double checked that my Order ID and email are correct and entered properly, and I’ve quite and reopened my webpage, and tried again with same results.

Any ideas on how to proceed?

is this a new installation or an upgrade?

Do you know if your host meets the requirements listed at the bottom of this page:

I wonder if sessions aren’t working on your server. Are you setting up on a new hosting account? Can you share the URL that you’re trying to install Backlight? I will look up your order to check it.

Thanks, Ben.

Yes, I’m trying to make a new install of Backlight 3 on a shared server. I have a brand new account, and this is my first attempt to install anything on the site. The URL is:

Of possible additional interest:
The first several times I tried to install Backlight 3, I got the message “Your host does not provide support for the ZipArchive PHP Package.” I talked to hosting support and I’m pretty sure they are now supporting ZipArchive PHP v7. The next time I tried to install Backlight 3 I ran into the problem described above that you responded to.

Thanks, Mike

Thanks for your reply, Rod.

This is a new installation on a shared server. See my response to Ben in this same discussion. When I purchased my hosting plan I showed them the requirements you mentioned (Linux OS, Apache server, PHP 5.4 or newer, SSLite and PDO modules enabled), and they said they met them. I am sure of the Linux OS part, and I think the PHP part, but I don’t know for sure about the other two. Do you have any suggestions for checking on this directly, aside from simply asking them again?

Thanks again, Mike

I’d wait on Ben, he’s the developer.

Hi Mike, I’ve had a look at your site. When I use your order number and email, I see the same issue. What you had entered is correct and matches with our database.
My hunch is that this is an issue with sessions not working on your server, which if that’s the case means there’s a misconfiguration on your host.

Can you try creating a new file on your server called session_test.php with the following contents:


$count = isset($_SESSION['count']) ? $_SESSION['count'] + 1 : 1;
echo 'count: '.$count.'<br/>';
$_SESSION['count'] = $count;


Once there, if you visit it should display count: 1 on first load, then count: 2 and so on for each subsequent page reload. If it stays at count: 1 then it means the sessions aren’t working.

If that’s too complicated then I can help out if you can share FTP access with me via direct message.


Yes, I’m afraid that’s over my head, so yes, I’d appreciate your help as you offered. I don’t see how to reach you by direct message, but you have my email, so can you email me and I can reply with whatever info you need?

Here are a few additional things that might be related:

  1. I’m not sure if SGLite and PDO modules are enabled.
  2. Before getting ZipArchive PHP enabled and updated to v7, I thought PEAR’s Archive_Zip was the correct module, and I enabled that. Is there a possible conflict there?
  3. When I typed my domain name into a browser to go to my site for the first time, I arrived at a gate keeper page that said something like “Check back soon for a new site, or if you’re the owner, enter your user name and password to go to cPanel.” I contacted GoDaddy and told them I didn’t want this page; rather, I wanted to see a blank page (meaning my own empty site), and he installed something (a file?) on my site that replaced the gate keeper page with a page that said “blank” at the top left. Not at all what I wanted, and I’ve had problems ever since. Could that have anything to do with the current problem?

Hi Mike, I’ve just sent you an email. I don’t think this is related to 1. or 2.
I think 3. may be closer to the mark. Do you remember subscribing to or enabling Cloudflare?
Can you check whether it’s enabled in your cPanel and if so disable it?

Cloudflare provides a layer above your website, and in our experience breaks session handling.