Issue upgrading from 1.2.2 to 3 (latest version)

Have 3 sites running 1.2.2 on a HostGator server - today I picked the simplest one to test the upgrade process from 1.2.2 to 3. Followed instructions in Rod’s “Tips & Tricks”. The process ran to completion (I think) but the patient died.

After the process completed I cannot access the site. Whenever I load its domain name into a URL window & hit enter, the server thinks for a bit then returns this in the URL window: and a message indicating too many redirects. Same issue as described by nigelsoultphoto on March 3.

I tried the solution you suggested to Nigel (and which worked for him) but it did not work here. I also tried the solution suggested for Panagon in June of 2020. Could not get it to work here. HostGator has the same range of PHP versions Panagon indicated for Bluehost.

I cannot figure out what is causing this - hints will be appreciated!!

Site is and it is a pure Backlight site. Images are uploaded from Lightroom & pages are created in BL page module.

I have a backup and can reload it and start over but wanted to hear your thoughts before I went that route.

Thanks for your great products!!

Bill Cobb
Sandy Springs GA

It sounds like a .htaccess file is in the wrong place.
Make sure the .htaccess and index,php files in the root of the unzipped Backlight-Installer download is uploaded to the root of the site and that the index.php and .htaccess files in the backlight/ folder of the unzipped Backlight-Installer download are uploaded to the site’s backlight/ folder.

Thanks Rod. I’ve tried that, but it has been along day here in the East so I’ll wait and try it again when I am fresh in the morning.

Thanks for your quick reply!!


Pretty sure we’ve seen this once or twice before, though I cannot recall the solution at those times. @Ben probably will have a notion, as this is very obviously a server or PHP thing.

When I hit the /backlight folder, I do see this errror:

Unexpected error: Version warning: Imagick was compiled against Image Magick version 1654 but version 1650 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0

… which does tell me that your server config isn’t quite where it should be.

But I’m able to access Backlight’s login and installer pages otherwise, and so I’m in agreement with Rod that something seems to be amiss with your pathing, which may be related to the .htaccess file.

Thanks Matt. I’ve gone through the .htaccess files again and results remained the same. I think it best to restore the old data and start the transition anew as there may have been some PHP version issues present during my first attempt. HostGator has not figured out how to repair the Imagick error without downgrading my PHP version which may be causing part of the chaos. I’ve also found an error indicating that I am missing the standard-album module. I’m pretty sure I used it for my page designs.

[09-Mar-2021 14:10:53] ERROR: Unable to find the module standard-album.Have you removed this from backlight/designer/modules? If so, either copy the module back, or change the template used by this album. in EngineFactory.php on line 405

You, Rod & Ben are great to work with - thanks for your support!

Got to backlight > Backlight Modules to install the Okapi Web Modules to get the standard-album module. You find this towards the bottom of the page.