Issue with TTG Publisher in Lightroom

I recently installed Backlight 3.1.1 and TTG publisher in LR 2020.
When I right click on TTG publisher to create a new album I get the create new album page and
a window “Unable to perform action: listTemplates.”
“The page sent an action that was not available.”

New albums are not created after I click save. Please advise.

thanks, Paul

Does your API url Authenticate?

No it does not.

Please also see screen shot.

does you API url match exactly to the site URL? (except for the /backlight/publisher/ part)

Yes. Seems like a permissions issue?
What permissions do I need?

Hi @pshilling, can you provide me with your API URL and key via direct message so that I can take a look?

Hi Ben,
I messaged you directly. Thanks, Paul

If you’re still wondering about permissions, there’s this, not sure if it’s relevant to what’s going on though:

I have attached another error message I recei ed when I tried to check authorization. Will this help? thanks, Paul

Hi @pshilling, thanks for the API key. I can see that error when I try to authenticate. There’s something amiss with PHP on your server. Is this a server that you’re managing or are you on shared hosting?

A workaround is to edit the file php.ini, if you have access to that either as system administrator or if that file exists under you public_html directory, and change the following line from:
(i.e. removing the leading semi-colon and changing 1 to 0)

If you don’t have access to that file, then you’ll need to take this up with your host’s technical support.

Thanks for looking into this. Do you still need my FTP username/password?

Hi Paul, no need for that now, unless further issues crop up.

Hi Ben,

With technical support assistance I made your suggested update to the php.ini file. Caused the error message that described the “jit = 1” issue to no longer display. However, did not solve the issue. Now when I Screen Shot 2020-09-27 at 2.14.30 PM

attempt to check authentication I get the attached message regarding “checkAuth” and when I attempt to create a
new album I get the attached error message regarding “listTemplates.” Please advise. Thanks, Paul

Hi Paul, your website has a redirect to www. Can you try changing your API URL setting in LR to include www. before shillingphotojewelry

Good catch. Issue solved. Thanks, Paul