JPG files not visible on website

I used to use Lightroom to publish to my website. I am now using other software and publishing via Backlight 4. I can publish two similar files, one can be seen and the other cannot. I get the message:
Here are the two files:

Photo_1.jpg is visible and Photo_2 is not.
Here is what is displayed…

I also checked the folders via ftp. Copies of both files the “master” folder are in the “photos”, and “thumbnails” folders. However, the files in “photos” and “thumbnails” are not “viewable” when downloaded.
Help please and thank-you!

can you provide a link to an album?

Is Backlight up to date?

What is your workflow for getting images into your albums?

Link: Test Album -
Backlight is up to date (one of the first things I checked).
Using On1 Photo Raw, export to jpeg and upload via publisher.
Photo_1 was exported from Lightroom, Photo_2 was exported from On1.
I have uploaded panoramas from On1 which work (Michele and Ian's Renos -…

I downloaded the photo you posted and was able to upload and view it on my Bl4 installation without issues.

Did you try to upload it a second time? When accessing the ‘master’ photo using ftp, is it viewable?

I have been trying most of this afternoon. The files make it to my server and can be seen using FileZilla. The files get converted however are not viewable on the website or if I snag them via ftp and look at them on my mac. (I hope that makes sense).

This gets more interesting, I downloaded Photo_2 from my post and uploaded it. It works! So what change in the file between posting it and downloading it? (Photo_2_try_2.jpg on the website).

Discourse might be doing some processing. I don’t know. Would you mind sending me the file or put it on your server with ftp?

Ok so I downloaded the master, photos, and thumbnails photos and ran identify on them, Photo_2.jpg in both the photos and thumbnails directories have errors:

astetner@ubuntu:~/Desktop$ ls master
index.html Photo_1.jpg Photo_2.jpg Photo_2_try_2.jpg
astetner@ubuntu:~/Desktop$ identify -verbose master/Photo_1.jpg > /dev/null
astetner@ubuntu:~/Desktop$ identify -verbose master/Photo_2.jpg > /dev/null
astetner@ubuntu:~/Desktop$ identify -verbose master/Photo_2_try_2.jpg > /dev/null

astetner@ubuntu:~/Desktop$ ls photos
index.html Photo_1.jpg Photo_2.jpg Photo_2_try_2.jpg
astetner@ubuntu:~/Desktop$ identify -verbose photos/Photo_1.jpg > /dev/null
astetner@ubuntu:~/Desktop$ identify -verbose photos/Photo_2.jpg > /dev/null
identify-im6.q16: Corrupt JPEG data: 68974 extraneous bytes before marker 0xd9 photos/Photo_2.jpg' @ warning/jpeg.c/JPEGWarningHandler/386. identify-im6.q16: JPEG datastream contains no image photos/Photo_2.jpg’ @ error/jpeg.c/JPEGErrorHandler/335.
astetner@ubuntu:~/Desktop$ identify -verbose photos/Photo_2_try_2.jpg > /dev/null

astetner@ubuntu:~/Desktop$ ls thumbnails
index.html Photo_1.jpg Photo_2.jpg Photo_2_try_2.jpg
astetner@ubuntu:~/Desktop$ identify -verbose thumbnails/Photo_1.jpg > /dev/null
astetner@ubuntu:~/Desktop$ identify -verbose thumbnails/Photo_2.jpg > /dev/null
identify-im6.q16: Premature end of JPEG file thumbnails/Photo_2.jpg' @ warning/jpeg.c/JPEGWarningHandler/386. identify-im6.q16: JPEG datastream contains no image thumbnails/Photo_2.jpg’ @ error/jpeg.c/JPEGErrorHandler/335.
astetner@ubuntu:~/Desktop$ identify -verbose thumbnails/Photo_2_try_2.jpg > /dev/null

It seems that Backlight or one of the php scripts is not successfully converting the master/Photo_2.jpg file. Thoughts?

That is probably good info for @ben and @Matthew.

What version of php is your host running on your site?

II just tried exporting an NEF file to jpg from On1 Photo RAW 2020 and uploading it via the Backlight publisher without problems.

You mentioned having success with some other images exported from On1. Was that recently or with a previous version of On1? I’m wondering if an update in On1 caused something.

Does this problem now always happen with exports from On1?

Thanks Rod and Daniel for your efforts.
I am in the process of uploading a bunch of test files to see if I can narrow it down. I did find a post on someone having a similar issue with jpegs created from camera files but that was back on PHP 5.
My server is currently running PHP 7.3.2. Everything breaks if I try 7.4 and 8 is nowhere to be seen on my provider’s config pages…

Well I don’t know what happened but everything is now working :grinning: :grinning: :grinning:
I tried a file of each type dng, nef, and jpeg and from three cameras and they all worked. I then tried to upload what failed the other day and it all worked.

Thanks for the assistance!
We can consider this item closed though I don’t know what the issue was. I assume it had something to do with On1 export to jpeg function…

Would probably be good for @Ben to get hold of the problematic JPEG. He might be able to determine the issue.

I will try to locate a “problematic” copy of the file. Where should I post it, it seems that uploading the file to the forum and downloading did something to the file (corrected it to some degree).

hi @astetner, can you please email it to ttgben [at] somethingchanged [dot] com?