Lightroom Publisher fails during publishing

I am trying to publish about 100 images from TTG Publisher on my test site. It is successful on a couple of images and then comes back with this error:


This is a new computer with all the images on an internal SSD drive. Any ideas?

Thanks - Monte

Are you using the latest Publisher plug-in?

Does Lightroom show the image files as being accessible? That is no “photo is missing” exclamation mark warnings?

Hi Rod. I have downloaded the latest plug-in and the files are there and accessible.

I tried a couple of things to no avail. I downloaded a fresh copy of the Publisher plugin and installed it. I created a new Publisher instance for the test site and created a couple of galleries, one with 100 images and one with six. They both failed to publish any images.

when publishing, you say that it’s successful for a couple of images and then fails. Can you then try again and get a couple more published?

Despite the error message that says the images are not accessible, I’m wondering if there may be a php.ini upload size limit getting in the way.
How large are the renditions? Are you also making renditions for digital downloads?

Can you try publishing a new album to your main site and see if that works?

One other thought. This could just be Lightroom weirdness. Try resetting the preferences file to see if that clears things up.

In the latest versions of LR Classic, you can go to Preferences > General tab. Hold down the alt key (Windows) Or the Option key (I think) for Mac and you’ll see a button that allows you to easily reset the Preferences file

It is weird. Some galleries, I can go in and mark a bunch of images to republish and it works, some it fails. I created a new gallery on my live site with seven images and is published fine. I added some images to an existing gallery and it failed to publish those.

The images are 1500px long edge max. No downloads.

I reset preferences and that did nothing that I can tell. I will do some more testing tomorrow (and document exactly what i did!).

Thanks Rod!

Hi @trummonte, who are you hosting with?

Does this fail on the same images? If you try to publish again do any of the images that failed to upload then succeed?

Hi Ben. I am with Dreamhost and I am no longer using Cloudflare. I will do some more testing today and document exactly what is going on. I know it has failed on the same images, but can’t say off the top of my head if it is consistent. Thanks!

Well this is enough to drive you crazy! Here are my testing results.

Live Site
Existing gallery (gallery-thumbnails) - 6 photos to replublish, failed.
Existing gallery (page-images) - added 1 image, failed. Added another, failed. Deleted failed images and added another, failed.
New gallery (test) - added 3 images, success. Added 10 more images, success.

Test Site
Existing gallery (landscapes) - marked 9 images to republish, succcess. Added 7 images, success.
Existing gallery (waterscapes) - had 14 imgages to replublish, failed. Added 5 images, failed.
Existing gallery (landscapes) - changes to use same template as waterscapes, added 3 images, success.
New gallery (test) - added 5 images, success. Added 15 images, success.
New gallery (test-2) - added 15 images, success.Marked 5 to republish, success.
Existing gallery (waterscapes) - Changed template from Pangolin-Client Response to Pangolin, had 14 imgages to replublish, failed on 6, success on the rest along with 5 images added earlier.

Testing Site
Existing galley (simple) - Had 6 new images to publish, failed. Changed template, failed. Changed template again, failed.Deleted images, added 5 new, success on 1, others failed.
Existing gallery (testing) - 6 images to publish, failed. Changed template from Kookaburra to Pangolin, success.
New gallery (testing-2) - Added 5 images, failed. Changed template from Kookaburra to Pangolin, success.
New gallery (testing-3 using Pangolin) - Added 6 images, success.

I regularly ‘clear the template cache’ because of a similar problem. Worth a try??

Thanks for the idea @DaveC, but it didn’t change anything for me.

I updated to 5.1.1 this morning and it seems to have solved this issue. Thanks!

1 Like