Metadata in Kookaburra

How can I get metadata in Kookaburra? Here (3. Júlí 2023 - Myvo ehf) I have used Pangolin Album to make metadata. Metadata One={D2} {FILENAME} i grid. and Tokens={FILENAME} shot with {CameraModel} lens {Lens} exposure {Exposure} on {D1} to get metadata (3. Júlí 2023 - Myvo ehf)

Same way as in Pangolin, in the album template.
In Kookaburra, look under the Caption and Image Metadata section of the template.

if I choose the essay option and enter the image uploaded with Kookaburra, the metadata doesn’t come up, but I get metadata if I load up by from the Pangolin Album and in the essay

I see what you mean. In a Kookaburra Essay I see the metadata beneath the slide show image, but none below the thumbnails.
II don’t recall if metadata ever did appear beneath the thumbnails.

if i insert Pangolin Album fotos the metadata comes under tumbnail 3. Júlí 2023 - Myvo ehf

Nice images! That location is incredible. Where is it?

There are a few things to understand when dealing with metadata, and I wish this were easier/clearer, but it is what it is.

First thing, images need to uploaded to an album with metadata tokens defined. If the tokens change, the images probably need to be re-uploaded.

Like pouring water, you need to set out the bottles you want to fill. You can’t get another bottle after the pouring is finished, and expect it to magically be filled.

Uploading an image, you need to set out the tokens you want to fill.

In Kookaburra, you have

  • Metadata 1
  • Metadata 2

^^^ These appear only on the grid, beneath an image thumbnail.

  • Caption
  • Subcaption

^^^ These appear in the slideshow, on single image pages, or beneath an image when using either the “single” or “static” layouts.

I hope that helps to clear things up.

Matt, should metadata be appearing under the thumbnails in a Kookaburra Essay if the template is configured for it? Because I’m not seeing Metadata 1 or 2.
and in the browser inspector, this is what I’m seeing:

If I change that to display:block;, the metadata appears.

That’s the caption, not the metadata. Captions are never displayed on the grid, only in large-image views (slideshow, single, static).

For metadata to appear in the grid, three conditions should be met:

  • metadata should be ON for the page
  • metadata should be ON for the album (e.g. not overridden to be hidden)
  • metadata must be present on the image (e.g. the image must have been uploaded to an album whose template is configured to display metadata; relevant when pulling images from a different album)

I’m publishing to a Kookaburra Essay album.
The page template has metadata enabled in both the Grid and the Slideshow.
In the album template. Grid Cell Metadata 1 and 2 are both enabled, but no metadata is appearing on the grid.

se this 3. Júlí 2023 - Myvo ehf

I found the problem. In some places formatted as metadataOne, and in others as metadata_one.

Those will need to be reconciled.

@rod_barbee Can you try this out?

Open file:



const metadata1 = photo.metadata['metadata_one'] || '';
const metadata2 = photo.metadata['metadata_two'] || '';


const metadata1 = photo.metadata['metadata_one'] || photo.metadata['metadataOne'] || '';
const metadata2 = photo.metadata['metadata_two'] || photo.metadata['metadataTwo'] || '';

Does that solve it?

I’ll have to get back to you. Looks like Bluehost is having issues and I can’t access my test site. Or any of my sub-domains, for that matter…

It didn’t solve it

I will have to try to reproduce the issue here to work on it then.

So, you’re publishing images with metadata to a Kookaburra Essay template? That’s it?

Yep. Also tried inserting pictures from that same album into a page. No metadata for thumbnails there either.

Tried clearing template cache, updating album files, and clearing browser cache. Also tried looking in different browsers and republishing album.

So, I think the best solution here is for me to revert to using the same property names as in pangolin. I had updated some naming convention in Kookaburra, but this is the source of the problem. This should allow things to be more consistent, including when migrating from pangolin to kookaburra templates.

The downside, however, is that anything published to Kookaburra will probably need to be republished to refresh its metadata. I dislike this, but it’s probably the lesser evil in making any fix here.