Multiple issues after installing latest module versions

After installing the latest module versions, I get ‘Allowed memory size of 268435456 bytes exhausted’ when trying to create a new album in Backlight, without photos. From LR Classic, I get a 161 error basically saying the same thing, but then find that 5 copies of the album appear in Backlight each time I try to create an album from LR, but they are not operable. LR Classic is up to date, PHP version has been changed multiple times: 8.0 and 8.1 will not work at all. 7.4 works but has same issues. I cannot change album names, or templates, or add photos. Everything worked great the last time I used this a couple of weeks ago, before installing the latest module versions. Any suggestions?

Hi @flpher, I’ve encountered this issue before and think I know what the issue is (a loop where the one album refers to itself as the parent, which causes queries to loop indefinitely and PHP to run out of memory).
Can you please share a Backlight admin login by clicking on my name in this forum then sending a Message from there? I’ll then check that this is the case, and fix it in the database.

Thank you so much.

I’m sorry, but this is new to me. Do I create another Admin login? If so, what username, email and password do I use?

Are messages sent in the forum private or must I do something to make them private? Again, sorry for my ignorance.

Thank you

messages are private, just click on Ben’s name.
You can create another admin login by going to Backlight > Users
username and password are up to you. I don’t think you need an email, but if you do, I think you can just use your own as this is just for temporary access

Hi Ben,

Now that I know how, I have created the Guest Adminstrator:
user: deleted
pass: deleted

I deleted the user name and password and sent them to @ben. @Daniel

Hi @flpher, thanks for the access. I’ve found that something’s not right with the “Photo Galleries” album sets. Firstly, there are two of them in the database. Secondly, neither of them seem to work at Thirdly, one of them (with id of 130074 had itself set as the parent.

The last point aligns with my thoughts on why the memory was running out. I’ve changed the parent_id of that album to be empty, so that it’s not self-referencing.

Can you see if that helps solve the memory issue?

Hi Ben,
It’s not showing a memory issue, but created a second copy of the Photos Galleries directory which prevented anything from working. I tried to upload one photo to a test gallery and itt appeared to go through until the last moment, which still give the error message:

The photo could not be uploaded: path was not found: home2/fireside/public html/

Hi @flpher, would you be able to provide me with FTP access so that I can try and work out what’s going wrong with your installation? Please do so via personal message.
Also, can I create test albums (most likely hidden, so they won’t be visible on your site) to see if I can replicate this or find any errors in the process?

Hi Ben,

Sorry it took so long to reply. I couldn’t get the temp FTP login for you to work, which I have now solved.
The original issues seemed to been resolved when I logged in through ftp and deleted all the references of the ‘galleries’ files. There were many, of which not all were not seen in backlight. I have included the FTP login for you below. Now an issue I cannot solve or find in the discourse is that I cannot create a second workable client response gallery. I have one that works properly, and a second one that will not allow selections and sending of choices. The templates are identical. Since you should still have the admin, you can create a client user if you want. (I wasn’t sure if I could create one without an email address for you and I can’t get it to work as a proctected access code only). The FMHSP0322 gallery works as expected, the ‘hangin with the hanks’ does not. Thank you so much for your patience with me.

FTP login info removed by moderator for privacy. Sent to @Ben via personal message

Hi @flpher, Rod passed me the FTP details that you had posted here. The password isn’t being accepted. Can you check that the details are correct, and if not provide the updated details by clicking on my name and messaging me directly from there?