No Album-Set Cover when Album-Set is password protected

Hi there,

I can not figure out how to set a Cover Image for an Album Set that is password protected.

I already found the documentation on how to set custom thumbnails. This works great but only on single Albums. As soon as I set a cover image on an album set it is displayed properly. But if I change to “password protected” in Lightroom the cover image is not shown.

Background: I’d like to set up an Album Set for each customers. This album set needs to be password protected.

Hope you can help

thanks and cheers

I believe that this is a security feature. Since the album set is private, that assumes all the images within that set are private and therefore are not shown as a cover image.

I thought that maybe this could be bypassed by uploading a custom image as the cover image (something like a jpg made in Photoshop with just text), but that didn’t work either.

That might be a nice feature though. (I have no idea if it’s possible)

For now, you’ll need to rely on the the title of the Album Set to identify it to customers.

You are believing right. But even using a cover image from the „custom_thumbnails“ album which is not in the protected album set will work.

I also have already tried to set the cover image manually by uploading directly to the set but this also does not work.

I always get this „image missing“ icon upon the album set name.

Would it be at least be possible to:

  1. disable icon on album set completely to have only text?
  2. set an alternative icon that looks better?

Thanks a lot

With custom css it should be possible.

this will remove the icon from the cell, leaving the cell empty (leaves the title and description in their fields):

.albums .no-thumbnail {

For text in place of the icon, you can use this custom css:

.albums .fa-file-image::before {
  content: "Private set";
  font-size: 36px;


For an alternate icon, you’ll need to find one you like in the Font Awesome options

Try using this code in your custom css:

.albums .fa-file-image::before {
  content: "\f1c5";

and replace “\f1c5” with the unicode for the icon you want to use. You’ll also probably want to increase the font size. For example, this code uses the “circle-user” icon:

.albums .fa-file-image::before {
	content: "\f2bd";
	font-size: 36px;


When you find an icon you like, look on the upper right for the unicode:

I’ve not tested this on mobile devices, so text and icons using larger font-sizes might look weird.

Also, any of the code choices will be applied to any set that’s missing a cover image, not just protected sets.