Pangolin journal album set not showing albums after update

I finally updated to Backlight 5 and ran into this. It was working fine before the update. The page only displays the page copy. The albums are there in Backlight Publisher. Any thoughts?

Thanks - Monte

The page is showing a 404 error trying to get an album via the API.

The request being made, resulting in the 404, is this:

Now, I have no idea what this bit is, or where it’s coming from:


If I remove that, and fetch this:

… then I get a 403, permission denied. Which I would expect, trying to hit your API from outside. Your site, making that same request, should succeed, and then load the response as page content, as we would expect.

So, do you have any idea what that extra garbage is or where it’s coming from?

I could – maybe should? – update the API scripts to strip such queries off the request URLs, if such exists. Still, we should like to understand why your site has that stuff.

Hi Matthew. Not sure where that is coming from! I just ran the update as usual… Anything you would like me to try?

I added another test news post (album) to see if it showed up, but it didn’t.

@Matthew I have played around with this on my test site. Clean install, downloaded the Starter Journal Template. It just will not display any albums. Any ideas? Thanks!

Double check your Backlight Settings to make sure that JSON API is enabled and that the albums aren’t hidden.

Also, according to the docs, Journal cannot be embedded into pages. Though that may have already been addressed in an update.

Hi Rod. I checked the JSON setting earlier and it is on and the albums are visible. If I set the album set to anything other than a journal, they show up. Does it work for you?

The r and cs parameters are actually part of our code. Looking into this, the issue seems to be that this is a Top-level Gallery and Backlight is trying to use the ID to find an album with ID of 4 instead of a top-level gallery with that ID. I’ll need to look further into this.

Updated to 5.1.1 and this is fixed. Thanks @Ben!