Problem Hiding Album

I’m setting up a client review and response site and I want albums to be hidden until the client provides an access code. I have followed the documented guidelines for setting visibility to “protected” and have enabled “Hide from Search” and “Hide from album sets”, and have set up access codes.

When I navigate to the album page, though, all images in the album are visible. The site currently has a simple structure, with the top level menu including:
Client Galleries

Under “Client Galleries” I currently have one page containing album images. When I select that client page from the “Client Galleries” dropdown, the client page with all images is displayed – there is no challenge for a password. What am I missing?

When you navigate to the albums page, are you logged into Backlight in the same browser? If so, this is normal. Try logging out or using a different browser than the one you’re using while logged into Backlight.

I was logged into Backlight on the same browser, so I logged out and tried it again - same result. I’m using Chrome, so I tried accessing the album page in Edge and Firefox with the same result… album images were displayed with no request for a password.

can you post a link so we can take a look?

the albums appear to be public.
Look in the album settings under the Features tab > Visibility.
I know you said that you’ve set them to “Protected”. Can you double check that?

Also, are you using the latest version of Client Response and the Lightroom Publisher plugin (if you’re publishing with Lightroom)? I’m unable to make selections or access the feedback on any of the images so I’m wondering if everything is up to date.

I checked the visibility settings again and can confirm that both albums (I added another one) have visibility set to Protected.

I checked in the Modules page and see that my versions are not all up to date (mostly one version back). I will update as necessary and let you know if that does the trick.

I updated all modules to latest versions, including publisher plugin, and albums are still not hidden.

And they’re still not working correctly.

Ben is going to need to take a look.

Would it help if I sent my login credentials by email?

couldn’t hurt

email to use?

you can direct message anyone in the forum by clicking on their icon and then the “Message” button.

I clicked on your icon and could not find a “Message” button.

Strange. I’ve received messages from others. You should see something like this (from clicking on your avatar) when clicking my avatar:

but if not, you can email me at: rod at rodbarbee dot com

I’ll take a look for anything obvious, but I still think Ben is going to need to take a look.