Problem with uploading photos in Backlight 2

I am still a Backlight 2 user (2.0.14)
My last upload with photos on my website was in Sep 2020
Today I want to upload (60) new photos in a new album again but it gives an error ??
attached screenshot of what is happening
(it is not because of photo 060, it happens to all of them even if I upload only 1 photo)
But I can’t upload photos in existing albums either…

I have already checked if I have enough space on my hosting server, that is good space enough

Can anyone help me solve this problem…?


Could your host have changed something, like updating php. What version of php is your site running.
(you can check by logging into Backlight and clicking on the View PHP Info link on the main dashboard

Out of curiosity, does clicking on the ? provide any further information? Like, any kind of error message or explanation?

Hi Matthew,
Look here:
Screenshot 2021-03-01 at 19.46.19


So helpful.

One more thing, if you’re up for it. In your browser, open the developer tools. In Chrome, right-click the page and choose “Inspect” is one way of accessing the tools; in other browsers you should be able to do similar, or go through the menu.

In the tools, one of the available tabs should be “Network”.

If you select that tab, you can see all of the inbound and outbound traffic for the current page. Try to upload an image, and a failure will probably create a red-colored entry.

Click that entry to see details, and post a screenshot of whatever it gives you.

Hopefully that will give us a start. If not, @Ben will probably need access to your admin area so that he can investigate.

Hi Matthew
Is this what you mean…?
tried to upload 5 pictures

and this when I click on one of the 5 red lines

Hi Peter, there’s something amiss with your host. File uploads aren’t being saved in temporary files as they are meant to be. This is likely due to a misconfiguration, or other disk error. I suggest taking this up with your host’s technical support.

1 Like

Hello Ben & Matthew

Thanks for help so far, I will contact my (VPS) hosting provider and keep you (all) informed here…

Peter Steehouwer

Thank you all for your help!
problem is solved :slight_smile:
See here the reaction of my VPS Host:

I have updated a few things, tried a few things and finally rebooted the server (it had been online for over 260 days without interruption)


Peter Steehouwer

Ha! Glad to hear it ended up being a trivial fix.

1 Like