The icon for images in essays disappeared

I wanted to go on writing and place photos but:

  • 1 photo disappeared
  • the icon to activate the photo-module of essays has disappeared

Logging out en in again doesn’t help
browser restart doesn’t help

In one of my test sites, I’m not seeing the image button in the album either.

But on my main site, Essay is working as expected.

The main difference to the two sites is that my main site is using PHP 8.0.28 and my test site is using PHP 8.1.16
What version of php is your site using?

EDIT: php version doesn’t seem to matter. I switch the test site to 8.0.28 and the main site to 8.1.16. Same results: Essay on test site not working correctly, but it is on the main site.

can you post a link to an essay so that @Matthew has something to look at?

@Matthew I have only one site and it just disappeared there from one moment on another.

What browser are you using?
I’ve been experimenting at I’ve found that where Essay albums from one test site aren’t working in Firefox, they are working in other browsers like Chrome, Brave, Opera, and Edge.

What’s strange is that in Firefox, Essay albums are working in another test site as well as my main site.

I don’t see the page throwing errors of any kind.

I do see that the last image group is displaying only one image, but asking for two. The missing image is ID 683874_74719.

But if I look at the payload coming back from the API call to fetch the album, there is no image in the album with that ID, hence it not being displayed. This indicated to me either that the image has been removed from the album, or that the ID is wrong.

As for the insert images button, I would need an admin login to look into it.

My browser is Safari. I’ll try a different one and if that doesn’t o the trick I’ll send you the id and PW. I don’t recall doing anything with that picture but replacing will give it another id so that won’t work I guess.

No difference in Chrome
How do I send the credentials to you Matthew?

Click on his name (@Matthew) then click on the Message button.

IT WORKS AGAIN!!! :smiley: :smiley: :smiley:

eh… all are gone now

It doesn’t get the images that have the keywords it is looking for. I published them again but no difference
Ah found that too… hide the picturs album for search and it looses them in the grid configurator

You’re using a smart album that is pulling some images from protected albums?

yes, protection by hiding is no problem but it went wrong when I hid it from search

It makes sense to me that if an album is hidden from search that the images within it would then not be able to appear in a smart album. But @Ben should know for sure.

So the problem is solved… but how? What did I do wrong or was it a glitch in the software? I’d like to know because if it was me i don’t want to make that mistake again… @Matthew @Ben ?

No clue. It’s now working in Firefox.

I suspect Nargles.


Harry Potter reference :smiley:

Bloody Nargles! :triumph:

Yeah, I don’t know. I didn’t get a chance to look into it yet (it’s been one of those weeks), but now sounds like I don’t need to. That’s good for me. And for you, I guess.

Anyway, glad it’s working!

Okay, not sure whether it’s what’s happening here, but I was tinkering on Rod’s test site, and this is the most likely problem.

There’s a JS function that sets up the image composer and attaches the button to open it. That function only runs when you are logged into the admin area of Backlight. On Rod’s site, this wasn’t working for me. The reason I found why is that I was logged into the site’s admin via this address:

But I was visiting the site via:

In this case, the “www” was all the difference. For purposes of being logged in, the two addresses are viewed by the browser as being separate sites. Make sure your addresses match in both tabs.

I am having the same issue. I am unable to place images within the essay as I used to do. I normally use Firefox, but after reading this thread, I tried Chrome and Edge. Neither of them gives me the ability to add images to my essay. I checked my web addresses for the backlight and the front end. They are same domain addresses. However my sites are all secure, ie https://. I wonder if that makes a difference. But it worked the last time I created an essay, 3 or 4 months ago with Backlight 4. I’m at a loss for what to try next. – Jon

I don’t know. If you want me to take a look, you’ll need to DM me your web address, and a login for Backlight’s admin.

Just wanted to update everyone on the problem I had, just to set the record straight. It was human error (mine of course), nothing related to backlight itself. Thanks to Matthew, I was able to get back on track. :+1:t3: Thanks Matthew.

1 Like