Unable to log on to admin on BL5

I am not able to login to my Backlight 5 dashboard? I am at:


I enter my user name and password, and it just cycles to the same screen, with empty fields and no error or warning.

I did the ‘forgot password’ link (though I was pretty sure I had it correct), created a new password, and still get the same behavior with the new one?

How can I get into my system, to change my portfolio?

Have you tried different browsers and clearing browser cache?

I just tried the default credentials and received an “Incorrect username or password” warning.

Hi @MindStormPhoto, Matt forwarded your email and I’ve been meaning to get back to you on this. I’ve looked at the two main culprits for this (sessions not working and your site being behind a content-delivery network) and neither seem to apply to your site.

Have you had any changes to your hosting lately, such as a change of PHP version or even moving to a new host?

I can’t think of any other cause. I can try to diagnose the issue via FTP if you’re able to provide me with access. If that works for you, please provide me with access by clicking on my Discourse username and then clicking Message.

I did move to a new computer. I went from a 2020 Intel MacBook Pro (maxed out) to a 2022 M1 MacBook Pro (maxed out).

No server changes though. In fact, they are still on an older PHP (7.3.7) and say they will not be upgrading anytime soon, for reasons I did not understand.

Rather than migrate from the older MBP to the new one, I opted to do it manually, one app at a time. That was because I had “auto migrated” at least 5 levels already and there weere kinks nobody (Adobe and Apple) could explain, plus the change of processor.

At any rate, everything else has moved over smoothly, but I am stuck on this site… :frowning:

Like I said above, I tried logging into your site using the default credentials (knowing it wouldn’t work). But I did get an error message.
Have you tried with other browsers? Are you still not getting any error message?

Well… yes and no. :sunglasses:

Before posting here, I had tried both Safari (my default browser) and Chrome (my backup browser). Same results. Cleared all cache on Chrome, and did a refresh on Safari (which should cause a reload of that page). I also rebooted the Mac. Same results.

HOWEVER… I just tried again now… and IT WORKS? I did nothing different (that I know of…) from my several days of frustration prior to posting here, but suddenly today I WAS able to log in???

PROBLEM SOLVED… for now. Rather frustrating to spend days failing and then suddenly, for no apparent reason, work… :face_with_raised_eyebrow:

I’m glad to hear that it’s working again. Since our code hasn’t changed, I’d put it down to something flakey on your host or on your network or PC.

If you do find it doesn’t work again, can you visit this page straight away to check that sessions are working? http://www.mindstormphoto.com/backlight/modules/module-framework/session_test.php

That is a test page isolated from all other Backlight code.