Upload_max_filesize exceeded while publishing collection


I use still Backlight 1.2.4. Now I’m trying to upload a collection to my website. I get this error message:

Can’t update this collection
Unable to perform action: uploadRendition.
Message: The uploaded file ezceeds the upload_max_filesize directive in php.ini.

The TTG Publisher shows in Lightroom that some of the photos are published, but I don’t find the album at my site.

It’s been a while since I uploaded the latest collection. It seems that php is updated at my site after my latest upload. Php version is 8.1.12.

I hope I’ll get some help.

  • Markku

you may have problems with the current version of php on a Backlight 1 site.

But to your question. you need to increase the upload_max_filesize in your php.ini file.
You may be able to download and edit this file from the root of your site via ftp. Or you might need to have your host increase the max_upload_filesize setting.

Thanks Rod!

Do you have an idea where that particular php.ini file could be located at my site?

If it’s there, it’s in the root of the site.
If it’s not there you may be able to create one in your host’s C-Panel

That seems to be managed by cpanel.

I found from Backlights “View PHP Info”:
Loaded Configuration File /opt/cpanel/ea-php81/root/etc/php.ini

Maybe I need to contact my web host’s support.

Another option to try is reducing the image rendition size/quality settings in the album template.

For some reason Puplisher has started to create quite big photo & thumpnail files compared to older albums. I managed to reduce the size to 900 KB - 1,3 MB. Thumpnails are of same size. But still publisher creates too big files and I get this error message.

The photos used to be around 100 KB and thumpnails around 25 KB. I haven’t changed settings in between - until now. I redused the photo size to 640 px and thumpnail size to 100 px in Template / Design / Image settings.

make sure your albums are using the correct template

Yes, they are using correct template. I have only one template designed. And, when I made the image size changes to that template, marked my collection in TTG Publisher to republish and then published the collection, the created files on my site are now smaller, but not small enough.

Propably this is the point where I should upgrade to Backlight 5.

are you also having publisher create download renditions?

That was “use photos rendition”. I’ll test “Create custom download rendition via Publisher” later today.

The custom rendition option will increase the amount of data you’re uploading.
I thought that if you had it turnrd on, it might be contributing to your issue.

Upgrading to BL5 is a good idea, though it may not solve your current problem with the upload setting in php.ini

Sounds like you’re getting bitten by the renditions bug that was introduced by Adobe some months ago. We posted updates, of course, and sent out a newsletter with the subject “IMPORTANT”.

In short, Adobe made a breaking change in their API, and older versions of publisher no longer respect your width/height settings for renditions. The impact is that publisher now exports thumbnails as full-size images. Not good.

We fixed this in Backlight 2 and newer. We very strongly advise an upgrade.

If you’re intent on trucking on with Backlight 1, though, then see here:

Thanks Matthew! That’s the way it works now.
I’m willing to upgrade to Backlight 5 really soon, but not yet. Too many changing things at the moment.

So, I’ll try those Publisher upgrades. My current Publisher application version is 3.2.4

Edit: And the update worked. Great!
Apologies about unnotifying that important mail.