Images won’t upload to albums

I have created a new album using TTG Publisher which will display on my website and it will not allowe me to add any images. I keep getting this error - Can’t update this collection. The rendition could not be created. Please ensure that the original file name is accessible, especially when stored on external or network storage.

There are no videos or invalid file types, I have remained them via lighroom and they are stored on an external hard drive. But I have also tried to upload an original file name image without success. I have also created a folder on my hard drive with the images in it, imported this into lightroom, added them to my target collection and still won’t upload. I have even used images from different shoots and still the same error message.

What can I do?


Hi @DebbieC, I’m not sure what’s going on there. Can you try to create a new album and publish at least some of the same images that have previously failed to the new album? This will help to narrow down where the problem lies.

Hello @Ben, I have the same error. However, it does not occur with all images. It must be related to BL5. Since the error also occurs with older albums in which only an update to existing images (image processing) has occurred. I have then test another installation with BL4 on a server. There the albums can be published. I use the current LRc version.


Hi @lema, as a developer I’m not keen on making assumptions without yet looking further into it (e.g. must be related to BL5). There are too many factors at play. There are multiple potential causes of this error, and without having heard further from @DebbieC, there is nothing more to go on.

Having said that, I would like to get to the bottom of what you’ve encountered. Can you help with the following:

  1. Do any of the images that fail to upload on older albums successfully upload on to a new album? (if you haven’t tried that can you please create a new album and try to publish some images that are failing to upload).
  2. Does this happen on any new albums, irrespective of whether those images exist or failed on older albums?
  3. Can you try to export some of the photos that won’t publish to see whether that works?
  4. Can you visit the Lightroom Plug-in Manager and select the Publisher, by The Turning Gate Plugin. What Version is given in the Status section? Are there any errors in the Plug-in Author Tools section? If the Save Diagnostic Logo to File button is enabled, can you try clicking it and reporting the output here?

Hi @Ben I am using Publisher version 7, but I also switched back to version 6.1.3 for testing. But this has shown no effect.

I have created a new album. All pictures which are not uploaded so far could be published in the new album.

I also set older albums to republish and completely re-uploaded. Again, the error occurred with individual images. These I have moved to the new album and uploaded. This worked then.

I have sent the logfile to you by mail.

Thanks for the support

Hi @lema, thanks for the further information. That does align with the experience of one other customer.
I don’t think this is related to the BL5 Publisher plugin. It’s looking to me that something has become corrupted in your LR Catalog. Assuming that’s the case, I don’t know whether that has anything to do with BL5 or an update to LR that has broken something.

I haven’t received a log file from you. Where did you send it to? ([redacted by Ben])

Can you provide a URL for an album that has photos that won’t publish?

Can you provide me with a URL to an album that has photos that can’t be republished?

Hi @lema, Thanks for the log files and access. I tried replying to your email, but my message was rejected as a potential virus!

Unfortunately, the logs don’t shed any light on the underlying cause.

Is this a good example of a photo that you can not replublish (in this exact album):

Hi @lema, can you try the following:

  1. Backlight your Lightroom catalog
  2. Run File > Optimize Catalog…
  3. Try republishing the photos in the old albums again

Hi @Ben, I have optimized the catalog and restarted LRc. The affected image in the old altbum cannot be uploaded. I have already sent the requested data to you by mail. Please contact me if they have not arrived.

Hi @lema, I’ve received your emails thanks.
Would you be able to provide me with a copy of your LR catalog? This should match the name you’ve given your catalog and be found in \Users[user name]\Pictures\Lightroom
The file should have the extension .lrcat.

This file may be very large. Zipping it may help, but it may still be too large to email. If that’s the case then uploading it somewhere else for me to download would be good.

Our conversation has given me a good idea to start looking into the catalog. What I’m hoping to do is follow the references for a given photo in both an album it can’t be published to and an album that it can, and to try to determine where in the catalog the data is broken. The catalog is actually a database file, in SQLite format, so it is equivalent to the databases that Backlight uses internally.

Hi @Ben, A good example would be the photo in the test album

I wanted to insert this into the album:
MANFRED LENDLE photography - Coronazeit
Here it always comes to the error.

I have then sent you a link for the download (Dropbox) of the LR catalog.

Hi @lema, thanks for sending through your catalog and for the better image example. I’ll see if I can find any issues in the catalog that may be affecting this.

This is happening to me also. I think this may relate to either the file size > 1mb or image resolution > 2k as a photos this occurs with I repeatedly cropped and then it published. Its not PHP I think, I have max filesize in php.ini set to 10M. Hoping this can be fixed soon.

Im pretty sure it is file size that is the problem with the plugin (or perhaps a PHP problem?) The issue seems to occur with file size > 1mb. I exported a whole number of files out reducing jpeg quality to 60% to reduce the file size to less than 1mb and then published these to backlight. All worked fine. Hope this can be fixed as I dont want to limit file size in this way to be able to bulk publish to backlight.

Actually, the issue appears quite random wrt to file size / resolution. With problem images that will not publish, they eventually do if they are cropped, even after the resolution / file size has been reduced.

Hi @tim.fidd, thanks for the details of your experience.

Are these issues using the LR publisher? Are you seeing the same error message as @DebbieC mentioned in the first post?

Hi @lema, I’ve examined the images in your catalog and can’t see anything amiss. In particular, the database details for the photo that can upload in one album but not another are identical. They’re the same file in the database.

What I can see is that the ‘photos’ renditions have been created and uploaded but the ‘thumbnails’ rendition hasn’t.

Can you try to republish the photo in the album that the photo upload previously succeeded in? Make sure that the publisher setting for pushing metadata without updating images is not enabled.

From LR publisher

Error uploading rendition. (Code: 413)

Bit it also fails if I try and add the problem photo to backlight/admin

But doesn’t fail in backlight/admin if I drop the reduced jpg size / resolution, but does fail in Lr publisher.