Install followed by Blankscreen

Hi All,

I tried to install Backlight 3.1 from scratch but after it says it has successfully installed it I get a blank screen …(if I go the root site I get ‘Backlight is not yet configured. Please login to Backlight to continue.’ …)

I did also install an older version (on a different site but the same server ) and this worked fine … any ideas ?


What is “blank?” Your site?

Are you able to log in to Backlight to configure settings?

blanks = empty browser window. once

  1. site/backlist/installer
  2. click ‘Install Backlight 3’
  3. ‘Backlight 3 was installed successfully’
  4. click ‘Continue to backlight’
  5. empty browser window from ‘site/backlight’ URL

… so I can’t even login … (the site runs on an update raspberrypi)

Sounds like something Ben will need to look at.
Can you also post a url to your site?

try this one:

not sure this helps, but the redirect (from - which shows ‘Backlight is not yet configured. Please login to Backlight to continu’) happens from this line of code in SQLiteHandler.php.

if (preg_match('/(admin|designer|publisher)\/master.sq3$/', $dsn)) {
					$backlightURL = URLHelper::currentPageURL().'backlight/';
					die('Backlight is not yet configured.  Please <a href="'.$backlightURL.'">login to Backlight 2</a> to continue.');

More specifically, it seems it bails on the ‘admin’ check … though not 100% sure

Do you know what version of php your server is using?

PHP 7.3.19-1~deb10u1 (cli) (built: Jul 5 2020 06:46:45) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.3.19, Copyright © 1998-2018 Zend Technologies
with Zend OPcache v7.3.19-1~deb10u1, Copyright © 1999-2018, by Zend Technologies

All that should help Ben. He’s in Australia so give it a few hours.

Hi Niels, it looks like Backlight may not have been able to copy over the database files, which would indicate a permissions issue. Are you using shared hosting, or is this a server or VM that you manage yourself?

If you’re on shared hosting then try setting the permissions for backlight/data to 755. If you’re managing your own server then set the ownership and permissions for that directory to something that the web server has permission to write to. You’ll likely need to make the same changes to your galleries directory in order to have Backlight create album files.

If that doesn’t look to solve it, then please provide me with FTP access via direct message.

Hi Ben,

the permissions were already set to 755 (and the uid/guid is set to the owner of the apache2 process - the installer can fetch and install the modules and create the directory - so the permissions do seem to be correct)

Hi Niels, are you using shared hosting, or is this a server or VM that you manage yourself?

If the latter can you see if there are any errors in the Apache error logs?

If that doesn’t shed any light on it then please provide me with FTP or SSH access so that I can look into it.

Also, is there anything in the backlight/data directory other than an .htaccess and index.html file? If there are directories, what are they named and do they have any contents?

Thanks for the SFTP access. Once again, are you the administrator of this server? If so, do you know how to configure it so that the right directories are writable?
Backlight assumes that you are using a well-configured server or know what you are doing as a system administrator. If you are stuck, I can help out further if you are able to give me SSH access with the right permissions.

Also, what are you seeing in your Apache error logs that may shed light on errors encountered when visiting ?

Hi Ben,
yes, server is owned by me (not a VM or container)
all directories are writable by owner (chmod 755)
no real error logs on apache (nothing that indicates a permission problem)

Okay. After a bit of debugging via SFTP I have found two missing settings that you’ll need to fix.

  1. Add index.php to your DirectoryIndex setting in Apache. It likely just has index.html.

Without index.php URLs such as won’t function. Whereas does respond correctly.

  1. Set AllowOverride All for the directory so that clean URLs will work

(e.g. browsing to will redirect to instead of the parameterised URL above.)

There may be more configuration items to change or fix, but the two above should progress things along.

Once those two are fixed, visit, login as admin and complete the setup.

it works, thanks Ben!

There are some more problems … the Lightroom plugin wants to connect to but I get a 404 from the server (I checked via tcpdump … it’s returns a 404.

the POST has this set as the referer: