Kookaburra and Pangdalin togeather

To try Kookaburra, I created a Kookaburra album within a directory that was within a Pangdolin created website/album set and the slide show thumb nails were found but the images said ‘image not found’

Anyway, i am not sure if this is a feature or an issue as the obvious workaround was to create a new kookaburra top level album set so the album sets above the album were all kookaburra created - that worked fine – so in fact it is no drama, just a feature or a curiosity :slight_smile:

Not the behavior I would expect. I’ve not had issues dropping Kookaburra albums into non-Kookaburra sets. Are you up-to-date with the latest Backlight 5?

Yes, updated to latest v5, I deleted failed page in favor of the one with the new top-level that worked but I guess the update of pages to Kookaburra would be easier if co-habitation in the same structure (sounds kookie fun) is supported; so I will try it again and let you know if the problem recreates.

Hi Matt, I took another run at converting some albums and sets to Kookaburra and somehow the images can not be found by the pages. Basically, I created KB Pages, Sets and Albums and assigned them to existing albums in lightroom and marked to re-publish and re-published. When I look at the Album from the Backlight album link all looks OK but then when I open the album in my browser the images are coming up. I tried clearing cache , rebuild index etc … An example is on this link where to my eye the Kookaburra page looks OK but when I open the page link it cannot find the images: Backlight This problem occurs when I change pages from pangdline pages to kookaburra in lightroom. If i create brand new kookaburra pages they work fine for me. I do not have anything so sensitive on my page - just family photos. Let me know if you need my password or you may already have it … thks a ton !!

ah - i just tried the page on my phone and it seems ok - problem is just on Microsoft Edge and Firefox. odd, huh ?

should work with all browsers. Can you share a link? (your link above leads to a Backlight login page)

Thanks Rob. Link is: https://bezy2.com/family/bl/2023/2310_ukraine2/

You may need username / password: testweb / BaiLongMa

The error message when clicking on an image is “image not found”; although I can see the thumb nails at the bottom of the screen and it works OK on my iphone.

Thanks again,

oops, need new eyeglasses - apologizes for misspelling your name …

sorry, I forgot about this and only now took a look. The login credentials don’t work

Thanks Rod. I just tried and they work. Anyway, as alternative please try: user: bezy , password: smile

strange. I’m seeing no images, just the filenames in the caption and broken image link icons. This is happening in all browsers on Windows: Firefox, Edge, Opera, Chrome, and Brave
@Matthew will need to take a look

Thanks Rod. The below link is what it was supposed to look like. I created the below as a by creating a new kookaburra album within a new kookaburra album set ( not changing the album template on an existing from Pangdolin to Kookaburra ) so I thought the problem was with the ‘changing album sets and republishing’; but now I do not seem to be able to create new albums in kookaburra … so i can not workout what exactly are ‘steps to reproduce’ vs the ‘steps to make it work’. At the moment I can only reproduce the problem. And I am wondering if it has something to do with my use of ‘directory permissions’ in cPanel and whatever that does to .htaccess file - which is something I have never understood but it seems to have some rules in it related to those broken links…?

Working link: https://bezy2.com/family/bl/2023k/2310k_ukraine2/

One more bit of info in case helpful: If , in lightroom, I change the album template on an album with the broken links back to an Pangdolin template and re-publish the album then it works fine.

You may be on to something with the directory permissions. @Ben is the one who will need to look at that.

Interesting. I’ve not tried assigning a Kookaburra template to an album that was initially assigned a Pangolin template.

I’m late to the conversation.

Just tried logging into the album, and I see images. No problem. So, you solved it?

I see you’re using server-side protection for the login, rather than Backilght’s own protection. And that is (or was) likely the problem. If the pages themselves did not have appropriate permissions to access the files in the protected folders, then loading those resources would fail. You need to be very careful when setting server permissions.

Should work just fine. The downside would be that Kookaburra wouldn’t have all of the renditions to work with that it would if you’d published directly to a Kookaburra template, but I’ve coded Kookaburra to use Pangolin renditions if that’s all it has. Makes migrating existing albums easy, and then Kookaburra becomes a progressive enhancement.

Thanks Matt, What is the best way to migrate to Kookaburra ? I thought going into lightroom and assigning the Kookaburra Album Template and then marking the album to re-publish and then re-publishing would be a good way to migrate albums to Kookaburra - but hit the above issue with that method. If the broken link issue I face in this method can be solved and I follow this method will it also create the renditions ?

You can assign the templates in Backlight.
Go to Publisher and click on the name of your top-level set. Then click on Assign Templates. After assigning, be sure to click on Save at the bottom of the page.

After assigning templates, if the problem persists, try going to the Backlight Special Links page (Admin > Special links) and click on Update Album Files.

I just tried publishing Pangolin albums from Lightroom and then changing them to Kookabura by either changing the template in Lightroom or Backlight Publisher. It worked either way.

1 Like