Publisher REALLY slow to upload

Just recently I have noticed it is really slow to publish galleries from within LR, I’ve checked all the BK modules are upto date and LR publisher, I’m not seeing any server updates recently that could have caused this.

Sometimes LR will hang on uploading and I have to restart LR and “publish” again , my server is running normally and I can upload other files via FTP at expected speeds.

So any advise as to how to even start to track the problem?

1 Like

How big are the output dimensions of the main images, thumbnails and images for download?

There’s a setting in Lightroom Publisher called “Delay API Requests by XX seconds.” You might try playing with that. Could be that the server is thinking the Publisher uploads aren’t legit.

See more about this setting here:

I’ve had a play with the “Delay API” setting unfortunately it doesn’t seem to make any difference, I.E 1 second or 20 seconds makes no difference at all.

Going back to LR version 11.1 appears to resolve the issue?

I haven’t tried publishing since the latest LR update. I’ll give it a go and see if things are slower for me too.

LR 11.2 Publishing does seem a lot slower.
I’m encountering the similar issues. One image will publish and then Publisher hangs. I have to quit LR and relaunch, publish another image (Publisher hangs again), quit LR, lather, rinse, repeat.

Did you revert to 11.1?

1 Like

Yes i went back to 11.1 and it seems to be back to normal.

I was finally able to publish an album of 8 images. The first two tries published only one image. The third try published the rest at what seemed to be a typical time.
I love intermittent problems… :face_with_raised_eyebrow:

Just tried adding three more images to the album and everything seems normal now.

Yes that’s what I am experiencing,

Me too with 11.2

I’ve uploaded a number of galleries on 11.1 this weekend and all works as normal, upgraded to 11.2 and the problem appears with hanging or VERY slow uploads… So defiantly looks like an issue with Publisher and 11.2 LR

I had exactly same problem - one image published then nothing more happen !!
I disabled the cloud sync in lightroom classic 11.2 - skye icon in upper right corner - and now publish runs at normal
Have a nice day


Unfortunately that doesn’t work for me, Cloud sync has always been disabled. I just loaded 11.2, checked cloud sync is off and same issue just hangs, loaded 11.1 all ok.

Something for Matt to look into I think?

Probably @Ben.
Or a bug report to Adobe

Not sure Adobe would be too interested in “when I’m uploading from The Turning Gate publisher my system hangs” :slight_smile:

Agreed, but it may be affecting more Publisher Service plugins than the TTG plugin

I’ll just throw out my experience with this issue.

I uploaded a few photos just now. They were in two albums, so I did two presses of Publish. The first one hung after one photo. When I shut LR down, it did not terminate all the way and I had to kill it with Process Explorer. After a restart, things published just fine in both albums.

As far as speed goes, it seemed slow, but that may just be a perception. That said, it was much slower publishing NEFs that it was with TIFFs.

This sounds like a Lightroom issue to me. Has anyone reported the problem to Adobe?

Does it seem slow to export the same images to desktop, or is the export only slow when using Publish Services? If anyone uses Publish Services for anything else – Flickr, or whatever – is the problem then also apparent?

I’m having this issue as well. I was wondering if it was HEIC conversion but sounds like everybody is having issues across the board. It’s just hanging on one image for about an hour now. Hope there is a solution.

I reverted back to 11.1 and it’s now back to normal. I was so relieved it let me open my catalogue that was made in 11.2. It’s definitely an issue specific to 11.2. Hoping we can get a patch so we don’t have to stay on 11.1 to use publisher

1 Like