Something went wrong - Image Magick

I’m getting this today. Not sure how to investigate. I’ve update all my modules to the latest version.

Something went wrong

Unexpected error: Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0

Updated message from my web host (Site5). At this point, I’m still receiving the error despite their update to my php.ini file. I will continue to work with them, but just wanting also understand if there is any sort of Backlight-specific change needed to further solve this on my side?

The issue is with the Image Magick version mismatch in the scripts and server. This does not impact the website’s performance. However, it will fill the error_logs file. You have to adjust the Image Magick version in your scripts 1650. However, normally if third-party applications like WordPress or Joomla, it is a bit complicated to do it. Thus, I have added the code ‘imagick.skip_version_check=true’ in the php.ini file which will skip the Image Magick version check, so that it won’t send the error about Image Magick to email or load the error in error_logs.

Hi @scottblackman, this error happens outside of Backlight, before Backlight has a chance to run. I’ll have a go at suppressing this error. Do you have options to change the version of PHP that your site runs on? While not specific to PHP itself, the error may be tied to your host’s setup of a particular version.

Thanks for the response Ben. The use of a php.ini file with in my album set directory with this code:


Solved the issue.
I asked them to further clarify the root cause of the issue and received this response:

I would like to inform you that we have recently upgraded our servers from EasyApache3 to EasyApache4. The website “” loads to the older PHP version whereas the server has the newer version and hence it is recommended to update the website scripts in order to resolve the issue.

I confess I’m not sure how to “update the website scripts in order to resolve the issue”. I’m assuming that is something I need to get back with them on and that it’s not something related to things I need to change within Backlight.

Hi @scottblackman, I’m glad you solved found a solution. Backlight reports all errors and warnings, so that we can be sure that no issues are hidden. The error is an issue with your host. We can hide it in Backlight (our ‘scripts’ as your host puts it) but can’t fix it as the issue is with the host.

Would you mind if I worked out a fix to suppress the error on your server via FTP? I think you’ve shared access with me before.

That would be fantastic Ben! Thank you.

I’m having the same problem (Site 5 is my web host). I’m not sure where to locate the php.ini file, though. Hi @scottblackman – could you you be more specific as to the exact location(s) where your are putting the file? A couple of places that I have tried at least get past the main error that gets thrown when the site is opened, but don’t fix the problem completely. Also, @Ben, if you have anymore advice I would be pleased to hear it. Thanks.

Bruce, it looks like your host expects the file to be called .user.ini and it should be in your public_html directory.

Here is the documentation I have found for Site 5:

Daniel, thanks for the Site 5 link. I tried this, namely creating a .user.ini file, which contains the “imagick.skip_version_check=true” line, in the public_html folder of my account, but it didn’t work. Maybe the file needs to be sourced to take effect, but I don’t no how to do that. After fiddling around, I found that placing two php.ini files (each containing the above line), one in public_html/backlight, and the other in public_html/galleries fixes the problem (at least for now). Thanks for the research.

PS to my above post: A big red “Something Went Wrong” error box shows up at the bottom of the page when a gallery is selected. This needs to get fixed somehow.

1 Like

What I determined (based on what Site5 had done) was that the user.ini file needs to be in the root of an album set directory. Having it there caused all my albums in these album sets to work correctly. So having it a the root of your domain directory isn’t something that cascades down throughout your site.

In addition - for whatever reason - the Site5 support team also changed the name of the file from user.ini to php.ini. Seems like it doesn’t necessarily matter.

With all that said, I’m still trying to address the steps they seem to be indicating I need to take with the change in PHP version on their side. Still a little fuzzy there. They seemed to be alluding to the need to update ‘site scripts’ on my end. Just simply haven’t had time to address things since Thursday.

@Bruce after looking further into this, we have a standard workaround for these errors.

Rename the file backlight/env.php.skel to env.php

Edit the file and remove the // from the line with SUPPRESS_STARTUP_ERRORS in it and save the file.

Hi @scottblackman, would you be able to provide me with a Backlight admin login? I’d like to see if I can make the setting to hide these errors available in the Backlight settings.

@Ben Thanks for the quick fix to suppress the warning message, it worked. Hope there is such an easy solution to the fundamental problem.

Which fundamental problem? The issue is a misconfiguration with your host. It’s likely I consequential.

Agreed, problem is with host.

Ben - I think I private messaged you with details. Let me know if you didn’t get anything.

Hi Ben,

I also discovered I have this problem today. I’m also with Site 5. I’ve done everything recommended here but I still have the big red warning box at the bottom of gallery pages. Is there any further guidance on how to make it go away?
I did this but it didn’t work:

Rename the file backlight/env.php.skel to env.php

Edit the file and remove the // from the line with SUPPRESS_STARTUP_ERRORS in it and save the file.

Thanks for any help!!

Hi @scott_walton, can you provide a link to your site where we can see the error?

Hi Ben, each gallery here: except the first one, “Recent Work” has the red box error at the bottom. For the recent work gallery, I added the .user.ini file with the ‘imagick.skip_version_check=true’ code to that directory and I guess maybe that is stopping that red working box? Do I just need to add that file to each of my gallery directories or is there a more global fix to take of them all? Thank you so much for any further assistance!