Unexpected error: Module ‘sqlite3’ already loaded in Unknown on line 0

got this error on backlight

reporting as requested…

Something went wrong
Unexpected error: Module ‘sqlite3’ already loaded in Unknown on line 0

See Ben’s reply here about “line 0” errors.

Also, this is your second topic about sqlite errors. Please contact your host, as this seems to be a problem with your service.

This is caused by PHP attempting to load the SQLite module in more than one place. If there is a php.ini file in your home or public_html directory when you access via FTP then try editing it and look for any line like extension=sqlite3. Comment-out the line by preceding it with a semi-colon, like this: ; extension=sqlite3

If you’re managing your own server then look for a similar line under the php settings in /etc/php

If neither option is available to you, then you’ll need to ask your host’s technical support to fix the issue.

Looking at the other SQLite topic you posted, it sounds like you’ve configured your own server.

Check that you have an SQLite config file under /etc/php/conf.d. If you do then I suggest editing /etc/php.ini and commenting out the extension=sqlite3 line there. You’ll need to restart Apache or the PHP server, if running php-fpm.

got it. thanks Ben!

there was an uncommented extension=mysqli . it must have caused a duplicate sql db reference. once commented out all galleries, including hidden ones are accessible.


PK