Upgrade from OKAPI to PANGOLIN

Consider pideja.ca/gbc which was originally built on the Okapi architecture and then upgraded to Pangolin, supposedly. I say this because looking at the Backlight templates page, I see that the Pangolin templates have no child templates or albums! I first noticed this when trying to change the typeface on the pages. In Pangolin: no change appeared, but when I changed the typeface on the Okapi templates, the new typeface appeared. Does this mean that the upgrade to Pangolin is not operational? Why?

Notice that I have yet to change the Album Set template…

I’d like very much to bring this site to the Pangolin standard and get rid of these Okapi templates.

You have only one Pangolin album template. It uses the GBC-page page template. You have not assigned that album template to any albums. That’s why you see no changes to those albums when you make changes to the Pangolin page template.

Thanks, Rod,
It’s been such a long time I edited in Backlight that I forgot about that!

Style fumbling around this Okapi to Pangolin upgrade…I want my Pangolin album pages to at least be identical to my Okapi album pages. But alas, many controls in Backlight have been changed and I am having a hard time adapting the pages from the Okapi look to an identical Pangolin page album look.
Consider: https://pideja.ca/gbc/galleries/19_luna/ that has been designed in Okapi and https://pideja.ca/gbc/galleries/15_carmina-burana/ that I am attempting to upgrade from Okapi. Quite different no? I am doing this thru PUBLISHER/ALBUMS/DESIGN witch would mean that would have to do every album individually. This is looking more and more like a chore!

Outstanding issues include:

  • formatting of thumbnails in albums;
  • including file names under thumbnails in albums;
  • applying selected typefaces (Lato from Google fonts) throughout the site, especially in albums.

And I thought that this upgrade process would be a snap to do!

that’s done pretty much the same way in Okapi and Pangolin: Thumbnail Grid > Metadata Display. Just add the {Filename} metadata token

How so? They both have Classic and Masonry. Pangolin adds the Justified presentation.

typography is handled nearly the same in Okapi as it is in Pangolin. In Pangolin albums you can also assign font type to the metadata, which is easier than it was in Okapi and the need for custom css.

I assume that I must now re-assign all Okapi-published albums to the Pangolin template. At the moment I have 25 Okapi and 2 Pangolin assigned albums. I guess there is no “wholesale” way to do this?

Working on the albums…
I deliberately placed the title (filename) area under the thumbnails yellow in order to clearly identify the area. When in “justified” mode the look is like this:

but, in “classic” mode, without changing any other setting, I get this:

The image does not “grow” to fit the borders as it did in Okapi.
There is no caption under the thumbnails. It should be the filename.
Consider an Okapi album:

Still looking for a solution.

Looking at the album thumbnails, I could live (for a while) with the smallish thumbnails but I need to have the file names under the thumbnails.
As for the large images, they are very much too small! They should be something like 640px wide by 1120px high approximately.
At the moment, I find the Okapi layout much better than what I can get from Pangolin. At least until I find how to control the Pangolin settings.

Did you remember to republish the metadata after making any metadata changes?

In Backlight, go to Publisher.
Click on “Albums” for the top-level set.
Click on “Assign Templates.”
You’ll see a list of all albums. next to each one you’ll see a drop-down to assign a different template to the album.
Just go down the list and make all needed changes.
When done, be sure to scroll to the bottom of the page and click the Save button.

What are the template settings for the large images?

Thanks Rod, I found it but before making wholesale template re-assignments, I try to get one template as I want it.

I naively thought that the Okapi settings transfered to the Pangolin directly.

In OKAPI, Backlight/Designer/Templates/GBC album/Design/Image Settings/Photos, I have
Height: 1920px
Width: 640px although, they effective dimensions are 640 x 940 approximately.
In Pangolin, Backlight/Designer/Templates/GBC-album/Design/Image Renditions/Photos, I have the same settings (1920 x 640) but, what is strange is that the large image page viewed on the page is thumbnail size(!) but when in Inspector mode, the image is as designed, 1135 x 640 pixels!!! See this Pangolin templated image: https://pideja.ca/gbc/galleries/20_la-belle-au-bois-dormant/GBC220603-8761-single.php

it looks like the page template you’re using for that album template has a bunch of left and right padding (250px ea) in the content area.

I’m looking into it, thanks.
Any idea why the page changes when I invoke the Inspector?

Fixed the large image - thanks
the thumbnails are still way to big but look good, for now. Should be a file name in that black box below each thumbnail…https://pideja.ca/gbc/galleries/19_luna/

Getting there.

not sure what you mean.