Uploading full-sized image problem

I had a problem earlier with errors with PayPal. I changed the PHP to 8.0, but now another issue has popped up.

After someone purchases a photo, I would then upload a full-sized non-watermarked image to the site for them to download.

When I tried to upload the image through Edit Digital Purchase page, it would error. See attachment

I think @Ben will probably need to look into it, but I have wild-ass guess you can try.
The error seems to have something to do with date. Check the Timezone setting in Backlight Settings and make sure it’s set to your time zone. It’s a long shot but worth a try.

Will do.

It’s correct. America/New York

@Ben I was able to duplicate this problem on my test site running php 8.0.16

@kurt I reverted to php 7.4 on my test site and the upload worked

I’ll give it a try.

Yes sir! It works fine with 7.4. Looks like we know php 8 is the problem.

Thanks again!

Hi @Kurt, in my experience PHP 8.1 has been the cause of most issues like this. I haven’t been able to replicate this error message, however I’ve put in a change to the code that should fix this and also fix the issue at Error during customer checkout via PayPal (which I also couldn’t replicate).

Can you try reinstalling the main Backlight modules by clicking ‘Reinstall’ under ‘Backlight’ on the Backlight modules page?

1 Like

HI @Ben I’m still getting an error using php 8.1. It happens when I click on the Update link in Cart > Orders

Something went wrong

htmlspecialchars(): Passing null to parameter #1 ($string) of type string is deprecated in HTMLHelper.php on line 128

Reverting to php 8.0 fixes that.

Uploading the offline download works for both php 8.0 and 8.1

I’ll do it shortly. Should I switch to 8 or 8.1?

Hi @rod_barbee, I have made another silent update to address the htmlspecialchars() issue. This and the earlier updates have been applied to both the testing and release streams.

1 Like

Looking good on both php 8.0 and 8.1

1 Like