Using home computer to develop website

I need to pull my website from my internet provider. Is it difficult to set up an environment on my home PC to host it until I find a new provider?

Not too difficult, depending on your technical skills.
You can use WAMP or MAMP to set up a local virtual server on your computer.

Thank you, Rod. I just needed some direction.

Hello again,
I realize this isn’t a support page for WAMP, but I thought I would ask if anyone has any experience with the error I encountered

when I tried to run the installer on my local installation.

I’ve not needed to use WAMP since the CE days of ttg. Those versions did not require a connection to an external server like Backlight does.
My guess is that you need to open a port (I think it’s Port 80) on your router.
This site should show you how:

Port forwarding is not the issue here. Can you select a different PHP version? Maybe 6.x or something like that? Or try downloading the installer again.

Thank you!

Thanks for the reply!

Here’s an update. I tried to skip the installation issues and simply moved the files from my provider to my WAMP server. The website is good but I can’t administer it. I tried redirecting the Site URL under Backlight settings to my computer but the admin is not fully functional.
Any thoughts?

what site url are you using in Backlight for the localhost?


is your site inside a folder named “home”?

No, actually, it’s under my OS under wamp64/www.

then try removing “home”

Hello, If I can successfully host Backlight on my home computer on WAMP, I’ll write up some remarks.

Thanks, that could help someone looking to develop locally before going live.

It was easy to do with the old TTG CE sites exported by Lightroom. But those didn’t depend on needing to reach out to the internet too.

Could be that @Ben or @Matthew have some experience with installing Backlight in WAMP or MAMP.

OK, thanks for your help!

I just did a Backlight 5 install from scratch and it works like a charm.

There might be a local firewall software running that blocks access. Can you access in a browser? If it works, you should get following message

Unable to specify controller and action: (, index)

yep, that’s what I get